[RESOLU]Push Eco Devices vers BDPV

Une question sur BDPV, un besoin d'aide : C'est ici !


Gratuit et sans engagement
http://www.bdpv.fr/fr/verifDevis.php


trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 07 sept. 2016 14:25

Je vous contacte par email pour accélérer les échanges.
Côté serveur, je n'ai plus aucun appel à l'url depuis le 5 Septembre, donc à priori cela vient de l'éco device.

David

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar Stp31 » 12 déc. 2016 02:25

Bonjour,

l'envoi de ma production depuis l'ECO Device ne fonctionnait plus depuis fin Juillet, et j'ai mis un certain temps à m'en rendre compte...
A l'automne, mes premières recherches n'avaient rien données.
Néanmoins, depuis le 10/12, j'ai effectué la modification indiquée par le message du 7/09,
à savoir remplacer dans le champ Serveur "bdpv.fr" par "www.bdpv.fr", et là, miracle!!!
Je recommence à recevoir des accusés de reception de production:
le premier message du 10 indique : Sauvegarde de l´index (index envoyé : 19876063 - Index min : 19869767 ...
du coup, je ne comprend pas d'où vient l'index Min? est-ce que ça ne devrait être le dernier index envoyé le 28/07 : 18693180 ?
Comment puis-je remettre à jour le site avec les production des 6 derniers mois (sachant que je dispose de l'historique mensuel sur l'ECO Device)?

Merci

Stéphane

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 12 déc. 2016 08:21

Stp31 a écrit :Comment puis-je remettre à jour le site avec les production des 6 derniers mois (sachant que je dispose de l'historique mensuel sur l'ECO Device)?

Petit mail à http://www.bdpv.fr/fr/contact.php

Il faut envoyer les différentes productions pour les 6 mois
et l'index du 1er décembre.

David

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar Stp31 » 13 déc. 2016 23:34

Merci encore, tout fonctionne à nouveau.

Stephane

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 06 janv. 2017 15:30

Bonjour,

Je viens de programmer mon EcoDevices pour envoyer automatiquement ma production vers le site bdpv (ce que je faisais manuellement depuis bientôt 10 ans !) et ... rien ne se passe !
Pourtant j'ai bien renseigné tous les champs comme indiqué sur ce forum et sur celui de l'EcoDevices.
Serveur : www.bdpv.fr ou bdpv.fr (j'ai essayé les deux suite aux post précédents)
Port : 80
Login : user:pass
Intervalle : 28800
URL : /_service/z_teleinfov2.php?util=****&mdp=****&index=$T104 avec **** et **** remplacés bien sûr par mon identifiant et mon mot de passe bdpv

Faut-il faire quelque chose de particulier sur mon compte bbdpv pour que cela fonctionne ?

Merci d'avance pour votre aide.

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 06 janv. 2017 15:59

Rien normalement.

Par contre je viens de regarder dans mes logs et je n'ai aucun appel de l'url par votre compte ctve .....
Pourriez-vous refaire un test et me dire ?

David

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 06 janv. 2017 16:30

Que puis-je faire de plus pour tester à partir du moment où j'ai renseigné tout ce qu'il fallait sur mon EcoDevices ?

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 06 janv. 2017 16:47

ctvebr a écrit :Que puis-je faire de plus pour tester à partir du moment où j'ai renseigné tout ce qu'il fallait sur mon EcoDevices ?

J'avoue que je ne sais pas ...... je n'ai pas d'eco devices ....

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 06 janv. 2017 18:12

Je pense que la situation s'améliore car, suite à une modification de configuration de mon Ecodevices, je viens de recevoir ce mail du site :

Bonjour,
Merci d´utiliser le service de téléinformation pour mettre à jour automatiquement votre production sur BDPV.
Votre compte est activé mais votre production du mois de Janvier ne pourra être mise à jour tant que vous n´aurez pas envoyé l´index de votre compteur de production de début de mois.. Pour les mois suivants, la production sera mise à jour à chaque export vers BDPV.

L´index de production envoyé : 10691488

L'index qui y figure est bien celui généré par mon Ecodevices mais, du coup, je ne comprends pas bien ce que je dois faire au niveau du site ?
Faut-il que j'envoie l'index qu'avait mon compteur de production début janvier ? Si oui je l'envoie ou et à qui ?
Merci d'éclairer ma lanterne à ce sujet et, ensuite, tout devrait rouler correctement :)

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 06 janv. 2017 18:18

ctvebr a écrit :Faut-il que j'envoie l'index qu'avait mon compteur de production début janvier ?

Oui, comme indiqué dans le mail :-)
Euh .... au père noël ? ;)
ou au support BDPV contact@bdpv.fr
:mrgreen:

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 06 janv. 2017 21:39

trebosc a écrit :Euh .... au père noël ? ;)


C'est bon, je viens de mettre mon index dans sa hotte ;)

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 07 janv. 2017 14:25

Cadeau envoyé :)

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 07 janv. 2017 14:35

Comme je viens juste de l'écrire en MP, peut-être sous une forme moins humoristique : merci Papa Noël ;)

Ceci étant, il semblerait que l'EcoDevice n'envoie pas ses données vers le serveur BDPV si on lui a programmé un port de consultation local autre que le port 80.
Je sais, cela n'a rien à voir avec l'envoi de données vers le serveur BDPV mais, hier lorsque je faisais diverses manips, c'est la seule modification que j'ai faite entre le moment où ça ne marchait pas (port local sur 1000 pour diverses raisons de configuration de mon réseau interne) et où ça s'est mis à marcher (retour du port local à 80).

Je vais en toucher deux mots à l'équipe de GCE Electronics via leur forum au cas où ...

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 09 janv. 2017 09:18

Bon et bien je me suis réjoui trop vite ...

Mon EcoDevice a semble-t-il bien envoyé deux relevés au site BDPV puis plus rien alors que je n'ai absolument rien modifié au niveau de mon réseau.
Je croyais, comme je l'ai indiqué dans mon post précédent, que c'était du au choix d'un port particulier différent du 80 pour la consultation locale (même si ça n'avait rien à voir) mais non. C'était une coincidence que l'envoi se soit fait juste après que j'ai ramené ce port à 80.
Je vais voir si je trouve un support du côté de GCE Electronics.

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3973
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 09 janv. 2017 09:34

Voilà les dernières traces que j'ai dans mes logs

[06/Jan/2017:16:49:24 +0100] "GET /_service/z_teleinfov2.php?util=ctve&mdp=index=10691488 HTTP/1.0" 200 343 "-" "-"
[06/Jan/2017:16:49:34 +0100] "GET /_service/z_teleinfov2.php?util=ctve&mdp=&index=10691488 HTTP/1.0" 200 343 "-" "-"
[06/Jan/2017:16:49:44 +0100] "GET /_service/z_teleinfov2.php?util=ctve&mdp=&index=10691488 HTTP/1.0" 200 343 "-" "-"
[06/Jan/2017:16:49:58 +0100] "GET /_service/z_teleinfov2.php?util=ctve&mdp=&index=10691488 HTTP/1.0" 200 343 "-" "-"
[06/Jan/2017:16:50:04 +0100] "GET /_service/z_teleinfov2.php?util=ctve&mdp=&index=10691488 HTTP/1.0" 200 343 "-" "-"
[06/Jan/2017:16:53:51 +0100] "GET /_service/z_teleinfov2.php?util=ctve&mdp=&index=10691488 HTTP/1.0" 200 343 "-" "-"


Rien depuis !

David

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 09 janv. 2017 09:39

Merci pour l'info qui va peut-être aider GCE

Ce qui est complètement délirant c'est que j'ai programmé un envoi toutes les 8 heures !!!
Là il y en a eu un toutes les 10 secondes environ ; c'est du grand n'importe quoi ...

Avatar de l’utilisateur
ruguA
BDPV
BDPV
Messages : 473
Enregistré le : 02 sept. 2016 14:58
BDPV : lestef
Departement/Region : 67
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ruguA » 31 janv. 2017 01:17

Il a peut être le bug de l'an 2017 ...

Pas d'update auto depuis le 24.01 à priori sur lestef ; j'ai cliquer sur sauver pour envoyer à 1h10 l'update de prod.

BDPV indique 81 alors que le système a produit 106.810 kWh ...
14 xSanyo HIP-214NKHE5 (17,7m²), SMA SB3000TL 2 stings, intégration Ubbink Solar / Intersol SE
Fiche BDPV
Autoconso à l'étude
Rester en monophasé : 6kVa en autoconso au surplus sur PDL de consso + 3 kVa en vente totale sur PDL de prod ?

ctvebr
BDPV
BDPV
Messages : 19
Enregistré le : 17 août 2010 21:52
BDPV : ctve
Departement/Region : 83
Professionnel PV : Non
Localisation : PACA - Var- (Est de Toulon)
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ctvebr » 31 janv. 2017 11:34

Depuis mon dernier post du 9 janvier ça fonctionne mais de façon assez curieuse.

En effet, j'ai programmé un envoi toutes les 4 heures. Le 1er envoi a eu lieu dans les secondes qui ont suivi cette programmation (à 12H15 pour être précis) et, depuis, cela fait un envoi à 12H15, 16H15, 20H15 puis plus rien jusqu'au lendemain 12H15.

J'ai remarqué en outre que, si je coupe le courant sur l'EcoDevices ou si je lui fais un reset, les envois reprennent bien aussitôt après, au rythme de un toutes les 4 heures, mais il n'y en a que trois par jour à : heure du reset, heure du reset +4 heures et heure du reset +8 heures puis plus rien jusqu'au lendemain.

A croire que pour l'Ecodevices les journées n'ont que 12 heures ... ou que son logiciel ait un bug au niveau de la gestion 12 heures/24 heures.

Ceci étant, tous les envois sont exacts pour ce qui est des données récupérées par BDPV donc je fais avec et je croise les doigts pour que ça continue :D

fanou
Messages : 1
Enregistré le : 07 juil. 2017 14:07
BDPV : fanou57
Departement/Region : 57
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar fanou » 07 juil. 2017 14:22

Bonjour à tous,

Ayant un peu eu de mal à réussir à configurer l'envoi depuis mon Eco-Devices, je partage ce que j'ai fait pour que cela fonctionne.
Tout d'abord il faut renseigner les infos avec ce qui est indiqué plus haut dans ce sujet:
Serveur : http://www.bdpv.fr (et non avec "bdpv.fr", ca ne fonctionnait pas pour moi, même si chez certains ca fonctionne)
Port : 80
Login : user:pass
Intervalle : 28800
URL : /_service/z_teleinfov2.php?util=****&mdp=****&index=$T104 (avec **** et **** remplacés bien sûr par mon identifiant et mon mot de passe bdpv

Ca c'est la configuration qu'il faudra mettre, mais il faut vérifier ces mail car de mon coté tant que je n'avais pas recu le mail de confirmation m'indiquant que le service de mise à jour était activé, il ne se passait rien sur le site. Il semble qu'en ayant forcé la maj en réglant l'intervalle à 60 (60 secondes), ca ait déclenché la chose.

Voici le mail recu :
Bonjour,
Merci d´utiliser le service de téléinformation pour mettre à jour automatiquement votre production sur BDPV.
Votre compte est activé mais votre production du mois de Juillet ne pourra être mise à jour tant que vous n´aurez pas envoyé l´index de votre compteur de production de début de mois.. Pour les mois suivants, la production sera mise à jour à chaque export vers BDPV.

  L´index de production envoyé : 23557035

Cordialement
L´équipe BDPV


Sans réception de ce mail, il semble que la remontée d'info vers le site ne se fasse pas.


Retourner vers « BDPV : Support »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré