[RESOLU]Push Eco Devices vers BDPV

Une question sur BDPV, un besoin d'aide : C'est ici !


Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 12 mars 2015 23:21

Bonsoir,

Vous aviez autre chose qui envoyait la production avant l'éco device ? Qui avait donc envoyé 13669 ?


En fait je n'avais pas vu ce mail du 9/3 quand j'ai fait ma première tentative :
[BDPV]Téléinformation V2 : Activation OK
Bonjour,
Merci d´utiliser le service de téléinformation pour mettre à jour automatiquement votre production sur BDPV.
Votre compte est activé mais votre production du mois de Mars ne pourra être mise à jour tant que vous n´aurez pas envoyé l´index de votre compteur de production de début de mois.. Pour les mois suivants, la production sera mise à jour à chaque export vers BDPV.

L´index de production envoyé : 13669918


J'avais tenté de configurer l'EcoDevice, mais j'ai aussi essayé en tapant la commande dans la barre d'adresse du navigateur.
C'est surement un des 2 tests qui a envoyé la donnée 13669918 qui s'est transformée en 13669

et dans la foulée, j'avais reçu ce mail :
Vous venez d´envoyer votre production sur BDPV.
Le traitement s´est bien déroulé.
Date de réception des données : 9/3/2015 - 0:1:16

Actions effectuées :
Sauvegarde de l´index (index envoyé : 13669 - Index min : 13669 - Index max : 13669918) Mise à jour de la production : 13656 kWh



De ce que je comprend de votre réponse:
La saisie manuelle et la "saisie" via écodevice sont indépendante donc le calcul de production est basé uniquement sur les index envoyés par teleinfo (13669 et 13703975)

Là il me faudrait l'index compteur au 1er mars (ce qu'aurait donc envoyer l'ecodevice le 1er Mars) pour que je stocke la valeur du 1er mars.
Ensuite si l'ecodevice expédie régulièrement l'index, cela ne posera pas de soucis le mois prochain (BDPV récupèrera tout seul l'index du 1er).

la suppression que j'avais tenté dans la page Saisie Production/Suppression de production n'a pas d'effet sur la valeur 13669 qui est stockée ailleurs.

Du coup pour la valeur de l'index au 1er mars ce doit être la valeur saisie manuellement le 28/02 au soir + 3 zéros pour passer en Wh, soit : 13598000
Ainsi ma consommation à ce jour sera 13711165-13598000= 113165 Wh soit 113,165 kWh, ce qui parait plus logique.

Pouvez vous corriger les valeurs mémorisées pour que cela fonctionne au prochain coup?

merci d'avance pour tout, et bravo encore pour tout le travail effectué sur le site BDPV et les forums associés.

Sinon, pour male44, mon EcoDevices était en firmware 1.05.05, je viens de le passer en 1.05.09b: on va voir si du coup j'ai le même problème que vous maintenant :?

Cordialement,

Stéphane

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3882
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar trebosc » 12 mars 2015 23:38

Stp31 a écrit :De ce que je comprend de votre réponse:
La saisie manuelle et la "saisie" via écodevice sont indépendante donc le calcul de production est basé uniquement sur les index envoyés par teleinfo (13669 et 13703975)
Là il me faudrait l'index compteur au 1er mars (ce qu'aurait donc envoyer l'ecodevice le 1er Mars) pour que je stocke la valeur du 1er mars.
Ensuite si l'ecodevice expédie régulièrement l'index, cela ne posera pas de soucis le mois prochain (BDPV récupèrera tout seul l'index du 1er).

la suppression que j'avais tenté dans la page Saisie Production/Suppression de production n'a pas d'effet sur la valeur 13669 qui est stockée ailleurs.

En effet.

Du coup pour la valeur de l'index au 1er mars ce doit être la valeur saisie manuellement le 28/02 au soir + 3 zéros pour passer en Wh, soit : 13598000
Ainsi ma consommation à ce jour sera 13711165-13598000= 113165 Wh soit 113,165 kWh, ce qui parait plus logique.

Pouvez vous corriger les valeurs mémorisées pour que cela fonctionne au prochain coup?

C'est fait.

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 12 mars 2015 23:55

Re bonsoir,
Je viens de recevoir le mail BDPV, donc ça marche avec le nouveau Firmware v1.05.09b.
Bien qu'ayant configurer l'Eco-Devices pour envoyer les données toutes les 8h, il ne s'est passé qu'un peu moins de 5h entre le précédent mail et celui-ci.
J'en déduits que l'Eco Devices envoie les données dès qu'on appuie sur le bouton Sauver de la page M2M.
Les mails mettent entre 15 et 30min à arriver.

Male44, du coup ça pourrait vous permettre de faire des tests plus rapidement sans attendre une nuit à chaque fois.

Cordialement,

Stéphane

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 13 mars 2015 00:01

Merci pour la modification.

mais est-il normal que la valeur 13697 soit encore présente dans la page Suppression de production ?
Le graphique de production affiche aussi cette valeur!
Dois-je la supprimer manuellement, ou va-t-elle être écrasée lors du prochain envoie de données?

Stéphane

Avatar de l’utilisateur
ericg
Modérateur
Modérateur
Messages : 4193
Enregistré le : 23 mars 2009 01:00
Localisation : 31

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar ericg » 13 mars 2015 08:05

Un seul envoi quotidien est suffisant pour BDPV, si possible la nuit de mémoire, les serveurs sont moins sollicités...
Remarque : L'ensemble de mes propos est personnel et mes interventions en tant que modérateur sont de couleur verte ou rouge
Image
Ma fiche BDPV - Mon site avec ma prod grace à Jsunnyreports*

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 13 mars 2015 08:47

Bonjour,

effectivement le dernier envoi vers 7h ce matin semble avoir réglé le problème, la production étant revenu à 113 kWh.
Concernant la fréquence de mise à jour, j'avais mis 8h car c'était la valeur mini conseillée pour ne pas trop surcharger les serveurs, mais je suis d'accord qu'une fois par jour suffit amplement.
Je le mettrai à jour cette nuit afin que le cycle de 24h soit synchronisé sur 1h ou 2h du matin.

Merci à tous.

Stéphane

Avatar de l’utilisateur
male44
BDPV
BDPV
Messages : 17
Enregistré le : 01 mars 2015 18:43
BDPV : male44
Departement/Region : 44
Professionnel PV : non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar male44 » 13 mars 2015 15:08

Bon visiblement ca ne fonctionne toujours pas je modifie encore 2-3 choses pour voir s'il y a des remontées... :oops: :oops: :oops:

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 14 mars 2015 01:03

Bonsoir,

si vous voulez m'envoyer des copies d'écran des différents ongles de votre ECO Devices (en masquant les mots de passes), je peux comparer avec le mien pour voir si y a de écarts.

Stéphane

Avatar de l’utilisateur
male44
BDPV
BDPV
Messages : 17
Enregistré le : 01 mars 2015 18:43
BDPV : male44
Departement/Region : 44
Professionnel PV : non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar male44 » 14 mars 2015 08:49

merci , je vois que d'autres se couchent tard...

Je viens de renvoyer une demande sur le support forum de gce ( http://gce-electronics.com/forum/viewto ... 81&start=0 ) et dès lundi j'appelle ( je ne sais pas si c'est faisable mais je pense de plus en plus à un problème hardware ( est ce possible pour du push ??? ))
voila un lien sur une de mes copies écran ( que j'avais envoyée précédemment )

viewtopic.php?f=91&t=32021#p371482

merci encore et bon we

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 14 mars 2015 09:43

Bonjour,

voici ma configuration de la page M2M:

http://imagik.fr/view/150184

Comme vous pouvez le voir, il y a quelques écarts:
- dans la case login, j'ai mis "user:pass"
- dans la case URL, je n'ai pas mis le "http://www.bdpv.fr", l'ECO Devices doit le reconstruire avec l'info de la case Serveur
Est-ce les valeurs des paramètres util et mdp dans l'URL sont bien ceux de BDPV et pas du forum (pour moi c'est le même login)?

Sinon, je suis étonné des valeurs de votre compteur dans les traces des différents messages que l'on peut voir sur le forum:
D'après votre fichier BDPV, en additionnant les valeurs des 6 dernières années, vous devriez avoir une valeur supérieure à 20348000 (en Wh), c'est à dire 20348 sur votre compteur de production (en kWh)
Cette valeur est visible sur la page Accueil/Configuration/Teleinfo1-XML : le paramètre <T1_BASE> devrait contenir une valeur de cet ordre là (à moins que vous n'ayez changé de compteur)

Stéphane
Modifié en dernier par Stp31 le 14 mars 2015 10:10, modifié 1 fois.

Avatar de l’utilisateur
male44
BDPV
BDPV
Messages : 17
Enregistré le : 01 mars 2015 18:43
BDPV : male44
Departement/Region : 44
Professionnel PV : non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar male44 » 14 mars 2015 10:09

Mea culpa, je ne suis visiblement pas reveillé, je n ai pas mis la bonne photo . J ai bien aussi bdpv.fr ( qui en effet se reconstruit ) login et mot de passe correspondent bien au site bdpv . Votre message confirme bien qu il faut utiliser user:pass . J ai mis $T104 car je suis sur le premier bornier de l ecodevices. J ai une Zibase quifait du push donc je ne pense pas avoir de probleme sur mon réseau ou de parametrage de freebox ... J ai des remontées de données de l ecodevices sur mon serveur synology ( ok en ip interne mais je peux aussi interroger l ecodevices en ip externe ) . Je ne sais pas si le parametrage du smtp est important , je l ai rempli avec les coordonnées free ( est la l erreur ??) . Je sèche

En tout cas bon we et j espère avoir des réponses lundi après midi auprès de gce

Avatar de l’utilisateur
male44
BDPV
BDPV
Messages : 17
Enregistré le : 01 mars 2015 18:43
BDPV : male44
Departement/Region : 44
Professionnel PV : non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar male44 » 16 mars 2015 16:50

Petites nouvelles du soleil nantais...

Ca y est ca fonctionne !!!! Apres avoir flashé 2 fois l'ecodevice , fait un reset et tout ca apres avoir appelé la hotline de GCE . Le technicien m'a fait réorienté le push vers son ordi et ca ne fonctionnait pas , pour lui c'était un conflit d'adresses ip chez moi, peut etre et sans doute , l'essentiel est que maintenant ca fonctionne :sun: :sun: . Dans la bataille j'ai perdu mes beaux graphes sur mon serveur mais je vais m'amuser à tout reconstruire.

Merci à vous qui ne m'avez pas laissé tomber , longue vie au forum et à bdpv.

Stp31
BDPV
BDPV
Messages : 14
Enregistré le : 12 mars 2015 02:16
BDPV : stp31
Departement/Region : 31
Professionnel PV : Non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar Stp31 » 16 mars 2015 21:43

Bonsoir,

Content pour vous que ça marche, on n'aurait surement pas trouvé en comparant nos configurations!
Du coup, c'est un vrai confort de voir les valeurs croître de jour en jour...

Par contre, pour la fréquence de mise à jour, il faut savoir qu'il y a une limitation dans l'Eco-Devices:
le compteur en seconde est plafonné à 65535 alors que pour faire un envoi quotidien, il faudrait y mettre 86400.
Couleur rouge réservée à la modération, laurent 35000
J'ai donc réglé l'envoi toutes les 12h (43200) vers 1h30 et 13h30.

J'ai demandé une évolution côté Eco-Devices (cf http://gce-electronics.com/forum/viewtopic.php?f=46&t=2229&sid=d3565fe4ca5f2500e7804460610cfa79&p=16770#p16770)

Si vous souhaitez passer également en mise à jour quotidienne, n'hésitez pas à soutenir cette demande (c'est vrai pour tous les utilisateurs de l'Eco-Devices).

Cordialement,

Stéphane

Avatar de l’utilisateur
male44
BDPV
BDPV
Messages : 17
Enregistré le : 01 mars 2015 18:43
BDPV : male44
Departement/Region : 44
Professionnel PV : non

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar male44 » 17 mars 2015 08:37

+1 je plussoie , et de ce pas je vais sur le lien . Il est plus confortable de voir le lendemain, par mail, la production de la veille...

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3882
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [ATT_REP]Push Eco Devices vers BDPV

Messagepar trebosc » 19 mars 2015 07:07

Parfait alors.

Merci pour votre persévérance !

David

Avatar de l’utilisateur
ruguA
BDPV
BDPV
Messages : 334
Enregistré le : 02 sept. 2016 14:58
BDPV : lestef
Departement/Region : 67
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ruguA » 04 sept. 2016 00:06

Si le mot de passe du site BDPV contient un caractère spécial autorisé lors de la création du compte, ça fonctionne aussi ?

Je demande ça car :
1. lors de la création du compte, le site BDPV prend bien en charge le cratère diese (ou hachtag pour les swags), indiqué comme autorisé
2. dans le profil du comte, lors de l'ajout du site web, impossible de valider : une pop-up s'ouvre pour dire que le seul caractère spécial autorisé est le tiret "-"
3. du coup si ça bug dans le profil du site, je me dis que le caractère spécial peut également gêner le site à récupérer des données !?!

:?
14 xSanyo HIP-214NKHE5 (17,7m²), SMA SB3000TL 2 stings, intégration Ubbink Solar / Intersol SE
Fiche BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=lestef
Autoconso à l'étude : viewtopic.php?f=25&t=34712&p=397299#p397299

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3882
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 04 sept. 2016 20:30

Petit bug de ma part.
C'est corrigé
David

Avatar de l’utilisateur
ruguA
BDPV
BDPV
Messages : 334
Enregistré le : 02 sept. 2016 14:58
BDPV : lestef
Departement/Region : 67
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ruguA » 07 sept. 2016 12:11

Concernant l'Eco Device & BDPV : chez moi cela ne semble pas fonctionner.

L'Eco Device dispose du dernier firmware ; les paramètres à insérer dans l'onglet M2M auraient changés depuis le tuto ?
14 xSanyo HIP-214NKHE5 (17,7m²), SMA SB3000TL 2 stings, intégration Ubbink Solar / Intersol SE
Fiche BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=lestef
Autoconso à l'étude : viewtopic.php?f=25&t=34712&p=397299#p397299

trebosc
Fondateur GPPEP
Fondateur GPPEP
Messages : 3882
Enregistré le : 23 juil. 2007 01:00
BDPV : trebosc
Departement/Region : 31
Professionnel PV : Non
Localisation : 31 - Midi-Pyrénées
Contact :

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar trebosc » 07 sept. 2016 12:26

Est-ce que le serveur est www.bdpv.fr (et pas seulement bdpv.fr) ?
Cela peut avoir un impact.

David

Avatar de l’utilisateur
ruguA
BDPV
BDPV
Messages : 334
Enregistré le : 02 sept. 2016 14:58
BDPV : lestef
Departement/Region : 67
Professionnel PV : Non

Re: [RESOLU]Push Eco Devices vers BDPV

Messagepar ruguA » 07 sept. 2016 13:27

J'ai testé avec les 2, ça ne change rien...

Et chez vous ?
14 xSanyo HIP-214NKHE5 (17,7m²), SMA SB3000TL 2 stings, intégration Ubbink Solar / Intersol SE
Fiche BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=lestef
Autoconso à l'étude : viewtopic.php?f=25&t=34712&p=397299#p397299


Retourner vers « BDPV : Support »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré