La V1.3 est en marche !

Modérateur : GPPEP - Conseil Administration



koi-2-9
Modérateur
Modérateur
Messages : 1178
Enregistré le : 28 déc. 2008 01:00
BDPV : PV_BZH
Localisation : 44 / Loire Atlantique - Bretagne
Contact :

La V1.3 est en marche !

Messagepar koi-2-9 » 22 oct. 2011 13:36

Martin s'est réveillé après quelques mois de sommeil :sun:

La version 1.3 est pour bientôt :
http://www.familie-kleinman.nl/jsunnyreports/

Oui, je sais, cela fait longtemps qu'il n'y a pas eu de nouveauté !.

Je travaille toujours sur JSR. Je vais essayer de mettre des nouvelles plus fréquemment les semaines à venir.
Je travaille actuellement sur la version 1.3.
Cette version va contenir diverses corrections de bugs, et quelques nouveautés

    de nouveaux onduleurs
    mise à jour du manuel
    corrections de bugs
    mg d'Uranium économisés
    amélioration des performances
    nouveaux graphiques (et un graphique de cumul des onduleurs si vous en avez plusieurs
    Et j'espère un nouvel écran pour l'onduleur dans l'outil de configuration

Plus d'info à suivre....
Remarque : L'ensemble de mes propos sont personnels et mes interventions en tant que modérateur sont de couleur verte ou rouge

Plus de jolie signature depuis que SFR a supprimé les pages persos...

Avatar de l’utilisateur
texan11
Membre GPPEP actif +
Membre GPPEP actif +
Messages : 395
Enregistré le : 30 août 2010 19:42
BDPV : texan11
Departement/Region : 11
Professionnel PV : Non
Localisation : Aude/Languedoc-Roussillon
Contact :

Re: La V1.3 est en marche !

Messagepar texan11 » 22 oct. 2011 13:39

bonjour
y a plus qu a être patient :D
Mes Aventures Photovoltaïques
Ma fiche BDPV Image membreImage
Image Sunny Explorer 1.02.7 Firmware SB 3000 TL 3.10

jsunnyreports
Messages : 20
Enregistré le : 22 avr. 2011 13:54
Departement/Region : FL
Professionnel PV : Non

Re: La V1.3 est en marche !

Messagepar jsunnyreports » 21 nov. 2011 17:05

Good news,

I have just released the first alpha version of 1.3. Including a scheduler, this improves performance quite a bit!

AlainVar
Messages : 2
Enregistré le : 03 juil. 2008 01:00
Localisation : 83

Re: La V1.3 est en marche !

Messagepar AlainVar » 21 nov. 2011 19:25

Bonjour

Ceci est est mon premier message
J'ai en projet de faire une installation de 7,8Kw avec 32 panneaux Solar Fabrik Pemium Incell L mono de 245 w
et un onduleur triphasé Kostal Piko 8.3.

Savez vous si cet onduleur est compatible avec Jsunnyreports?
merci d'avance
Alain du Var

Avatar de l’utilisateur
gridained
BDPV
BDPV
Messages : 115
Enregistré le : 03 mars 2011 15:00
BDPV : gridained
Departement/Region : Aube
Professionnel PV : Non
Localisation : Verrières 10390 Aube
Contact :

Re: La V1.3 est en marche !

Messagepar gridained » 21 nov. 2011 20:58

Testé, marche pour moi sans souci (sous Ubuntu 11.10)

Avatar de l’utilisateur
pepe69
Membre GPPEP
Membre GPPEP
Messages : 76
Enregistré le : 20 janv. 2011 12:33
BDPV : pepe69
Departement/Region : 69
Professionnel PV : non
Contact :

Re: La V1.3 est en marche !

Messagepar pepe69 » 21 nov. 2011 21:32

Bonsoir,

Testé également chez moi sous windows 7, a priori RAS, tout va bien. Je n'ai pas encore mis en place le scheduling proposé par Martin

A suivre

daniel05
Messages : 119
Enregistré le : 29 sept. 2011 20:24
BDPV : daniel05
Departement/Region : 05
Professionnel PV : NON
Localisation : 05- Hautes Alpes

Re: La V1.3 est en marche !

Messagepar daniel05 » 23 nov. 2011 18:24

Bonjour a tous...
J'ai installé le patch de la v1.3 comme indiqué sur le petit tuto rajouté par Jsunnyreports, mais je n'ai trouvé aucunes différences avec la version précédente...Ai je pas fait ce qu'il fallait ? Pourtant sur mon site il est indiqué Version 1.3...
A vous lire, ceux qui ont expérimenté l'ébauche de la nouvelle version.
Merci d'avance de donner votre point de vue...

Avatar de l’utilisateur
pepe69
Membre GPPEP
Membre GPPEP
Messages : 76
Enregistré le : 20 janv. 2011 12:33
BDPV : pepe69
Departement/Region : 69
Professionnel PV : non
Contact :

Re: La V1.3 est en marche !

Messagepar pepe69 » 23 nov. 2011 19:20

daniel05 a écrit :Bonjour a tous...
J'ai installé le patch de la v1.3 comme indiqué sur le petit tuto rajouté par Jsunnyreports, mais je n'ai trouvé aucunes différences avec la version précédente...Ai je pas fait ce qu'il fallait ? Pourtant sur mon site il est indiqué Version 1.3...
A vous lire, ceux qui ont expérimenté l'ébauche de la nouvelle version.
Merci d'avance de donner votre point de vue...

Bonsoir Daniel05,
Ce que j'ai pu comprendre est en fait un changement sur la partie generation de "repport" surtout pour ceux qui font tourner l'outils plusieurs fois par jour. Les info codées dans schedule.ini evitent de generer des repports pour rien et juste une fois par jour, pour le reste semble t'il pas de changement importyant car comme moi tu retrouve tes petits avant et après mise a jour

A suivre pour d'autre péripéties

Avatar de l’utilisateur
gridained
BDPV
BDPV
Messages : 115
Enregistré le : 03 mars 2011 15:00
BDPV : gridained
Departement/Region : Aube
Professionnel PV : Non
Localisation : Verrières 10390 Aube
Contact :

Re: La V1.3 est en marche !

Messagepar gridained » 02 déc. 2011 15:56

Voila elle est enfin sortie en version 1.3.1.0 !
http://forum-photovoltaique.fr/viewtopic.php?f=79&t=23928

daniel05
Messages : 119
Enregistré le : 29 sept. 2011 20:24
BDPV : daniel05
Departement/Region : 05
Professionnel PV : NON
Localisation : 05- Hautes Alpes

Re: La V1.3 est en marche !

Messagepar daniel05 » 02 déc. 2011 18:31

Bonsoir Gridained et tous les autres..
Je viens de tester la nouvelle version de JSR 1.3.1.0 et effectivement elle transmet les données avec une rapidité approchant 90% de gain...On ose plus croire que le site est deja a jour.. :sun: :lol:
Je conseille a tous ceux qui utilisent les versions précédentes de tester cette nouvelle version, elle en vaut vraiment la peine et félicitations et encore grand merci a Martin...

daniel05
Messages : 119
Enregistré le : 29 sept. 2011 20:24
BDPV : daniel05
Departement/Region : 05
Professionnel PV : NON
Localisation : 05- Hautes Alpes

Re: La V1.3 est en marche !

Messagepar daniel05 » 06 déc. 2011 09:48

Bonjour a tous,
J'ai testé les versions 1.3.1.1 et elle se plante quand on change de date, en fait elle fonctionne tres bien le jour de l'installation. Attendons donc la version définitive...

philip05
BDPV
BDPV
Messages : 80
Enregistré le : 10 avr. 2011 21:53
Departement/Region : 05
Professionnel PV : non

Re: La V1.3 est en marche !

Messagepar philip05 » 06 déc. 2011 10:21

Essaye de la réinstaller, peut-être qu'un problème est survenu lors de l'installation et de la copie des fichiers :idea:
:sun: :sun: :sun:

daniel05
Messages : 119
Enregistré le : 29 sept. 2011 20:24
BDPV : daniel05
Departement/Region : 05
Professionnel PV : NON
Localisation : 05- Hautes Alpes

Re: La V1.3 est en marche !

Messagepar daniel05 » 06 déc. 2011 13:28

Bonjour Philippe...Non j'ai essayé plusieurs fois de la réinstaller mais elle plante quand on change de jour...sinon la version 1.3.0.0 est active mais je ne trouve pas de grosses différences avec celles précédentes...donc a suivre.......... :sun:

Doudy
BDPV
BDPV
Messages : 153
Enregistré le : 17 mars 2009 01:00
Localisation : Belgique - Hainaut

Re: La V1.3 est en marche !

Messagepar Doudy » 06 déc. 2011 17:28

J'ai installé la version 1.3 le 02/12
Aujourd'hui je viens de constater que dans la vue annuelle (index.allyears) n'est plus exacte, Idem avec Rendement annuel actuel (index.yearyield).
J'ai une différence de 260,829 KW
Je réinstalle la version antérieure.

L'affichage de la vue quotidienne ne s'affiche pas complètement non plus (1/3 supérieur uniquement)

J'ai réinstallé la version jSunnyReports-1.2.0.0 beta6 et là les chiffres sont corrects
Ma fiche utilisateur BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=doudy
------
Mon suivi de production : JSunnyReports :http://www.gdoudy.be/jsunnyreports-pi/index.html
------

bennoz44
Messages : 21
Enregistré le : 28 janv. 2010 01:00
BDPV : bennoz44
Departement/Region : 44
Contact :

Re: La V1.3 est en marche !

Messagepar bennoz44 » 07 déc. 2011 18:37

Aujourd'hui est sortie la version 1.3.1.3. Elle fonctionne nickel chez moi depuis quelques jours (j'étais "beta tester" suite au signalement du plantage de la 1.3.1).

Pour la mise à jour :

Depuis la Version 1.2.0.0beta6
-------------------------------------------
Faire un sauvegarde complète du répertoire avant toute chose.

Remplacer jsunnyreports.jar par celui de l'archive ZIP.
Supprimer tout ce qui se trouve dans le répertoire /lib et extraire celui de l'archive ZIP.
Copier schedule.ini et schedule_optimized.ini depuis le ZIP vers le répertoire /conf

Depuis une version 1.3.1.0Lightning
--------------------------------------------
Faire un sauvegarde complète du répertoire avant toute chose.

Remplacer jsunnyreports.jar par celui de l'archive ZIP.
Supprimer les 2 fichiers avec l'extension .jsun ( filecache.jsun, inverterdata.jsun ).


Depuis une version 1.3.1.1Lightning
--------------------------------------------
Remplacer jsunnyreports.jar par celui de l'archive ZIP.


Bon test !
Chez moi, avec une relève toutes les heures, il faut désormais 18-19secondes pour que jSR traite les données, crée les graphs et les envoit (FTP).

daniel05
Messages : 119
Enregistré le : 29 sept. 2011 20:24
BDPV : daniel05
Departement/Region : 05
Professionnel PV : NON
Localisation : 05- Hautes Alpes

Re: La V1.3 est en marche !

Messagepar daniel05 » 08 déc. 2011 17:01

Bonsoir Bennoz44, j'ai essayé la dernière version mais elle se plante au niveau du FTP, pourtant j'ai rien modifié...

Avatar de l’utilisateur
bidulechou
Membre GPPEP
Membre GPPEP
Messages : 482
Enregistré le : 17 mars 2010 19:07
Departement/Region : 38
Professionnel PV : Non
Localisation : 38 - Isère

Re: La V1.3 est en marche !

Messagepar bidulechou » 08 déc. 2011 19:04

Patience, Martin a corrigé le souci et devrait faire bientôt la version 1.3.2

Ancient FTP error surfaced
Thursday, December 8, 2011 Posted by Martin Kleinman
Comments (0)

Since 1.3.1.3, in this version FTPIgnore is removed, people can get the following error:

FTPCommand - create directory : 2009
Fatal error, an unknown error occured.
java.lang.NullPointerException
at nl.mk.jsunnyreports.ftp.FTPEngine.traverse(FTPEngine.java:142)
at nl.mk.jsunnyreports.ftp.FTPEngine.traverse(FTPEngine.java:143)
at nl.mk.jsunnyreports.ftp.FTPEngine.traverse(FTPEngine.java:143)
at nl.mk.jsunnyreports.ftp.FTPEngine.doFTP(FTPEngine.java:193)
at nl.mk.jsunnyreports.JSunnyReports.main(JSunnyReports.java:152)
Class: nl.mk.jsunnyreports.ftp.FTPEngine Method: traverse. Line: 142
Class: nl.mk.jsunnyreports.ftp.FTPEngine Method: traverse. Line: 143
Class: nl.mk.jsunnyreports.ftp.FTPEngine Method: traverse. Line: 143
Class: nl.mk.jsunnyreports.ftp.FTPEngine Method: doFTP. Line: 193
Class: nl.mk.jsunnyreports.JSunnyReports Method: main. Line: 152



This issue is caused by not checking an object if its null. And to make matters worse, this error has been sitting in our code since the beginning. Somehow in the previous version the nullpointer exception was wiped under the carpet.

The code is fixed now and tested. I will release 1.3.2.0 tonight.
Image - Membre du Image - Statistiques Consospy
Image

Avatar de l’utilisateur
pepe69
Membre GPPEP
Membre GPPEP
Messages : 76
Enregistré le : 20 janv. 2011 12:33
BDPV : pepe69
Departement/Region : 69
Professionnel PV : non
Contact :

Re: La V1.3 est en marche !

Messagepar pepe69 » 08 déc. 2011 21:29

:| Meme problème, la solution temporaire est de faire le transfert FTP via Filezilla. Un peu plus long mais au moins les données sont rechargées sur le site Web.

D'après les commentaires de Martin, bug identifié et corrigé dans un upload qu'il devrait mettre en ligne cette nuit :P

Avatar de l’utilisateur
pepe69
Membre GPPEP
Membre GPPEP
Messages : 76
Enregistré le : 20 janv. 2011 12:33
BDPV : pepe69
Departement/Region : 69
Professionnel PV : non
Contact :

Re: La V1.3 est en marche !

Messagepar pepe69 » 09 déc. 2011 13:52


daniel05
Messages : 119
Enregistré le : 29 sept. 2011 20:24
BDPV : daniel05
Departement/Region : 05
Professionnel PV : NON
Localisation : 05- Hautes Alpes

Re: La V1.3 est en marche !

Messagepar daniel05 » 09 déc. 2011 14:16

Bonjour a tous,
je viens d'essayer la 1.3.1.4 et apparemment tout a l'air de fonctionner :sun: Faut attendre un peu avant de donner une appréciation définitive ainsi que les résultats...en tout cas le bug concernant le FTP est corrigé... Bonne journée a tous


Retourner vers « jSunnyReports »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré