Script pour lancement automatique SunnyExplorer

Modérateur : GPPEP - Conseil Administration



koi-2-9
Modérateur
Modérateur
Messages : 1178
Enregistré le : 28 déc. 2008 01:00
BDPV : PV_BZH
Localisation : 44 / Loire Atlantique - Bretagne
Contact :

Re: Script pour lancement automatique SunnyExplorer

Messagepar koi-2-9 » 28 mars 2013 07:26

as tu essayé avec une version antérieure ?
J'ai connu le même problème avec la 1.02, il restait un truc qui ne se fermait pas bien, d'où le problème.
Un retour à la 1.1.11 a réglé le problème.
Remarque : L'ensemble de mes propos sont personnels et mes interventions en tant que modérateur sont de couleur verte ou rouge

Plus de jolie signature depuis que SFR a supprimé les pages persos...

Doudy
BDPV
BDPV
Messages : 153
Enregistré le : 17 mars 2009 01:00
Localisation : Belgique - Hainaut

Re: Script pour lancement automatique SunnyExplorer

Messagepar Doudy » 28 mars 2013 09:35

koi-2-9 a écrit :as tu essayé avec une version antérieure ?
J'ai connu le même problème avec la 1.02, il restait un truc qui ne se fermait pas bien, d'où le problème.
Un retour à la 1.1.11 a réglé le problème.


C'est quand même terrible qu'il faut installer une version précédente afin de faire fonctionner le bidule...
Chercher l'erreur...
:lol:
Ma fiche utilisateur BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=doudy
------
Mon suivi de production : JSunnyReports :http://www.gdoudy.be/jsunnyreports-pi/index.html
------

koi-2-9
Modérateur
Modérateur
Messages : 1178
Enregistré le : 28 déc. 2008 01:00
BDPV : PV_BZH
Localisation : 44 / Loire Atlantique - Bretagne
Contact :

Re: Script pour lancement automatique SunnyExplorer

Messagepar koi-2-9 » 28 mars 2013 19:41

Doudy a écrit :C'est quand même terrible qu'il faut installer une version précédente afin de faire fonctionner le bidule...
Chercher l'erreur...
:lol:


Note bien que la V1.02 ne fonctionne pas chez moi, mais très bien chez d'autres.
En tout cas, cela a résolu mon problème.
Remarque : L'ensemble de mes propos sont personnels et mes interventions en tant que modérateur sont de couleur verte ou rouge

Plus de jolie signature depuis que SFR a supprimé les pages persos...

Doudy
BDPV
BDPV
Messages : 153
Enregistré le : 17 mars 2009 01:00
Localisation : Belgique - Hainaut

Re: Script pour lancement automatique SunnyExplorer

Messagepar Doudy » 08 avr. 2013 08:37

koi-2-9 a écrit :as tu essayé avec une version antérieure ?
J'ai connu le même problème avec la 1.02, il restait un truc qui ne se fermait pas bien, d'où le problème.
Un retour à la 1.1.11 a réglé le problème.


J'ai cherché désespérément la version 1.1.11 sur le net.
Ne trouvant pas, je suis allé sur le site de SMA, trouvé et installé la nouvelle version 1.06.14 de SunnyExplorer et magnifique plus de soucis.

http://www.sma-france.com/fr/service/telechargements/dlf/U3VubnlFeHBsb3JlclNldHVwMTA2MTQ%253D/download.html?type=281&cHash=990814e8ac87b626f0597820645794c0


:sun:
Ma fiche utilisateur BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=doudy
------
Mon suivi de production : JSunnyReports :http://www.gdoudy.be/jsunnyreports-pi/index.html
------

koi-2-9
Modérateur
Modérateur
Messages : 1178
Enregistré le : 28 déc. 2008 01:00
BDPV : PV_BZH
Localisation : 44 / Loire Atlantique - Bretagne
Contact :

Re: Script pour lancement automatique SunnyExplorer

Messagepar koi-2-9 » 10 avr. 2013 19:07

Doudy a écrit :J'ai cherché désespérément la version 1.1.11 sur le net.


Tu as cherché sur ton forum préféré ?
Tu l'aurais trouvée :lol:
Remarque : L'ensemble de mes propos sont personnels et mes interventions en tant que modérateur sont de couleur verte ou rouge

Plus de jolie signature depuis que SFR a supprimé les pages persos...

Doudy
BDPV
BDPV
Messages : 153
Enregistré le : 17 mars 2009 01:00
Localisation : Belgique - Hainaut

Re: Script pour lancement automatique SunnyExplorer

Messagepar Doudy » 11 avr. 2013 07:09

koi-2-9 a écrit :Tu as cherché sur ton forum préféré ?


En effet j'ai cherché sur Google et pas sur le forum :roll:
Ma fiche utilisateur BDPV : http://www.bdpv.fr/fiche_utilisateur.php?util=doudy
------
Mon suivi de production : JSunnyReports :http://www.gdoudy.be/jsunnyreports-pi/index.html
------

pascal69480
BDPV
BDPV
Messages : 36
Enregistré le : 18 mai 2015 15:21
BDPV : pascal69480
Departement/Region : 69
Professionnel PV : Non

Re: Script pour lancement automatique SunnyExplorer

Messagepar pascal69480 » 26 juil. 2015 23:41

Bonsoir,

J'ai essayé d'utiliser le script de Texan adapté par Etinet.
Ca fait un moment que je le tourne dans tous les sens et je ne parviens pas à trouver ce qui cloche.
En effet le batch ne trouve pas le fichier du jour et tente donc de le générer par Sunny Explorer en ligne de commande.
D'après ce que je vois, l'export se lance bien... seulement impossible de trouver le fichier CSV généré.
Et au lancement suivant, rebelote pour l'export puisque le fichier n'est pas trouvable.

Voici les traces console du batch :

Code : Tout sélectionner

D:\PV\jsunnyreports>maj2
Le fichier spécifié est introuvable.
Il y a 0 lignes dans le fichier "D:\PV\pascal69480\pascal69480-20150726.csv".
exportation 20150726 23:36:47,85
CSV-Export: establishing connection to plant ...
CSV-Export: plant login started ...
CSV-Export: current plant time is 26/07/2015 23:37:13
CSV-Export: starting export \nCSV-Export: completed
jSunnyReports. Copyright : 2009-2015, Martin Kleinman, Martijn van der Pauw & Ba
stiaan Schaap, version 1.6.1.0 build final Codename 'Spring'. Builddate : 12-06-
2015 at 19:00
jSunnyReports. The solar equivalent of the Swiss knife!
Check out http://www.jsunnyreports.com for the latest version.
Loaded: filecache.jsun
Loaded: inverterdata.jsun
-----------------------------------------------------------------------
-----------------------------------------------------------------------
Done loading inverterData ( time used : 30ms )
-----------------------------------------------------------------------
-----------------------------------------------------------------------
Nothing changed
-----------------------------------------------------------------------
-----------------------------------------------------------------------
FTPTransfer
-----------------------------------------------------------------------
1: Connecting to FTP ftpperso.free.fr with username: xxxxxxxxxxx
1: Done processing all files, closing this thread
Done in : 419ms, average speed: - kB/sec.
Cache didn't change, nothing to write.
-----------------------------------------------------------------------
Done processing ( time used : 794ms ), exiting program.
-----------------------------------------------------------------------


J'ai tracé également la ligne de commande générée par le batch et j'ai essayé de la lancement unitairement : il ne semble pas y avoir de problème mais je ne trouve aucun fichier généré :(

Code : Tout sélectionner

"C:\Program Files (x86)\SMA\Sunny Explorer\SunnyExplorer" "D:\PV\pascal69480\pascal69480.sx2" -userlevel user -password "********" -exportdir "D:\PV\pascal69480" -exportrange 20150726-20150726 -export energy5min


Merci d'avance, tout aide sera la bienvenue !


[EDIT] En relisant tous les messages de ce fil, je constate qu'il y a des écarts selon les versions de Sunny Explorer.
Pour ma part j'utilise la v 1.07.23

Je vois demain si je dois creuser cette piste ...


Retourner vers « jSunnyReports »