Suivi Linky: beaucoup d'erreurs checksum :(



petitgik
Messages : 6
Enregistré le : 13 mai 2019 15:07
Departement/Region : 92
Professionnel PV : Non

Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar petitgik » 13 mai 2019 15:39

Bonjour à tous,

En utilisant un Raspberry pour récupérer les trames Linky configuré en mode Standard (9600 bds), je me suis rendu compte que de nombreuses trames ont des erreurs checksum. Pour rappel, le contenu de la trame et le checksum sont envoyés à la suite par le Linky.

Exemple de trame erronnée:

LTARF HDURE CREUSE (checksum K)

J'ai pourtant vérifié : le câble de connexion aux fiches I1/I2, le module de Teleinfo (un module de GCE electronics), l'isolation des câbles entre eux, un problème software sur le raspberry, etc.

Voici la courbe du nombre de trames (code+contenu) contenant une erreur checksum par minute, en fonction de la date de capture: https://ibb.co/q966nhZ

Le nombre d'erreurs explose juste avant minuit, et ceci sur plusieurs jours. Il y a des pics a 600 erreurs/minutes! Mais en moyenne on serait autour de 100 err/min environ. Je précise que je capture environ 2500 trames par minute, donc dans les pics, 24% des trames sont erronées...

Vu la régularité des pics, et la corrélation par rapport à l'heure du jour, je ne soupçonne pas le câblage (interférences) mais plutôt le Linky lui-même: serait-il perturbé par la télétransmission des informations chaque nuit?

Avez-vous remarqué un comportement similaire chez vous?

Merci!

silicium81
Membre GPPEP
Membre GPPEP
Messages : 2407
Enregistré le : 04 mars 2009 01:00
BDPV : silicium81
Departement/Region : 81000
Professionnel PV : non
Localisation : 81

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar silicium81 » 13 mai 2019 16:26

L'interface teleinfo du linky est réputée comme nécessitant une mise en forme plus sensible (le signal fourni est moins fort). C'est peut être ce qui arrive à votre interface qui a peut être du mal à générer un signal propre...
CGE Electronics à un forum...
Modifié en dernier par silicium81 le 13 mai 2019 16:28, modifié 2 fois.
Producteur d'électricité depuis le 17-08-2009 2940Wc en Rec Solar, SMA3000 TL-20, Intersole
+ 14,4kWc en Sunpower, SMA7000HV, Bac Acier (20 MWh produits par an)
BDPV 3kWc et sujet
BDPV 14,4kWc et sujet
Mon petit forum technique http://vae-tech.forumactif.org/

JujuY
Modérateur
Modérateur
Messages : 8626
Enregistré le : 13 juil. 2009 01:00
BDPV : jujuy
Departement/Region : 69
Professionnel PV : Non
Localisation : 69 / Rhône

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar JujuY » 13 mai 2019 16:27

Peut-être faut-il vérifier la conformité électrique de ton récepteur (et son câblage) aux spécifications d'Enedis (impédance du câble, impédance de charge, détection niveau 0 et 1) La téléinformation en mode Standard est plus contraignante que celle en mode Historique
Yves

Remarque : L'ensemble de mes propos est personnel et mes interventions en tant que modérateur sont vertes ou rouges

Image Prod. jour maxi : 65,59 kWh, 22/06/12, Puis. maxi sur 1 min : 10,02 kW, 06/05/12 Firmware onduleur SMA : 3.01

petitgik
Messages : 6
Enregistré le : 13 mai 2019 15:07
Departement/Region : 92
Professionnel PV : Non

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar petitgik » 13 mai 2019 17:16

Très bien je vous remercie pour vos réponses
Je vais vérifier ça.
Effectivement le mode standard transmet 8x plus rapidement que le mode historique donc cela peut introduire plus d'erreurs.

Avatar du membre
laurent35000
Modérateur
Modérateur
Messages : 11749
Enregistré le : 04 avr. 2008 01:00
BDPV : laurent35000
Departement/Region : 35
Professionnel PV : non
Localisation : 35 / ille et vilaine / bretagne
Contact :

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar laurent35000 » 14 mai 2019 10:26

Je confirme, problème de signal , sur les arduino, ce qui fonctionnait avec les compteurs bleus ne fonctionnent pas avec les LINKY, la résistance d'entrée est a changer( c'est toujours en cours chezmoi)
Remarque:mes interventions en tant que modérateur sont verte ou rouge
Ma fiche BDPV ImageMembre du ImageMa production en liveImage

petitgik
Messages : 6
Enregistré le : 13 mai 2019 15:07
Departement/Region : 92
Professionnel PV : Non

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar petitgik » 14 mai 2019 13:45

Merci! Tu peux préciser : quelle résistance et de quelle partie (linky, module teleinfo, raspberry, ...?)

Avatar du membre
laurent35000
Modérateur
Modérateur
Messages : 11749
Enregistré le : 04 avr. 2008 01:00
BDPV : laurent35000
Departement/Region : 35
Professionnel PV : non
Localisation : 35 / ille et vilaine / bretagne
Contact :

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar laurent35000 » 14 mai 2019 14:00

Sur ma carte arduino en entrée de signal il y a une résistance et c'est celle ci qu'il faut changer(peut pas t'en dire plus, c'est pas moi qui gere :?)
Remarque:mes interventions en tant que modérateur sont verte ou rouge
Ma fiche BDPV ImageMembre du ImageMa production en liveImage

petitgik
Messages : 6
Enregistré le : 13 mai 2019 15:07
Departement/Region : 92
Professionnel PV : Non

Re: Suivi Linky: beaucoup d'erreurs checksum :(

Messagepar petitgik » 18 mai 2019 16:51

Bonjour à tous,

Je viens de tester la même installation avec un module concurrent (Module Teleinfo USB TIC Rail DIN de Domoticz), et celui-ci n'a aucune erreur. Cela vient donc bien du module GCE qui n'est pas la bonne résistance à l'entrée du module...


Retourner vers « Branchement ENEDIS (ex ERDF) / EDF »