Montage Kit Optimiseur



rolrider
Messages : 86
Enregistré le : 14 mai 2018 10:35
Departement/Region : 78
Professionnel PV : non

Montage Kit Optimiseur

Messagepar rolrider » 31 janv. 2019 00:07

Montage Kit Optimiseur

Le but de ce tuto est d'essayer de visionner les différentes étapes et d'éviter certains pièges concernant la V2 sur les nouveaux compteurs.
Le tuto de la V1 "Programmation/Montage/Câblage" se trouve ici http://forum-photovoltaique.fr/viewtopic.php?f=110&t=39159


Je commence par démonter le clips noir et les deux vis. (que je garde précieusement).
je serre (pas trop fort) les deux vis (qui serviront aux sorties Ch1 Ch2)
Pour éviter qu'elles tombent lors de l'ouverture du compteur et de se retrouver à 4 pattes sur la moquette !
Image
Il faut aussi découper au cutter l'étiquette de certification pour ouvrir le capot supérieur.
Image
Les deux parties sont ouvertes, attention aux câbles jaune/vert/blanc de ne pas trop tirer dessus.
juste pour info et lorsque vous remontrer le boîtier, l'encoche du PCB se positionne sur l'ergot,
voir flèche.
Image
Regarder si le PCB sincère correctement, un ajustement à la lime où papier de verre peut être utile.
Vous pouvez retirer et conserver les deux borniers à vis.
Image
Commencez par remplacer le condensateur, retirer le jaune en chauffant les plots de soudures,
c'est du double faces et il faut...un certain temps pour que la chaleur se diffuse correctement
pour dessouder le condensateur jaune.
Pour positionner le gris (1µF) je ne retire pas la soudure des plot....trop compliqué et en chauffant,
ça risque de provoquer plus de problèmes.
Je garde les pattes longues, je pose une patte sur l'emplacement du trou, et je pose le fer (chaud)
sur la patte au plus proche du PCB côté fil jaune/vert/blanc, la soudure fond et je pousse la patte de quelques centimètres
pareille de l'autre coté, jusqu’à ce qu'il soit bien positionné, je finis par une soudure de l'autre côté.
Image
Le voilà en place.
Ensuite il faut déplacer les deux languettes métalliques (sur la photo du haut, c'est déjà fait).
Image
Elles se dessoudent facilement, et avant de les ressouder à côté, j'étame l'arête pour y souder le câble plus facilement (sur les deux).
Il nous reste à préparer et positionner le jack dans le boîtier.
Image
Personnellement, j'utilise du câble provenant d'un vieux cordon rj45, les câbles monobrin sont à proscrire.
Pour le jack (c'est la partie la plus délicate) je coupe la languette la plus grande à la même longueur que l'autre.
Pour gagner un peu de place et j'utilise la gaine rétractable au plus juste (fourni avec le kit) toujours pour éviter une longueur
trop importante qui gênerait la fermeture du boîtier. Un conseil, brancher votre pince sur le jack et vérifier sur les extrémités des câbles au multimètre que
vous avez bien environ 100 d'ohm, ça évite de démonter le boîtier et de refaire le câble suite à une erreur de plot (il y en a trois et deux seulement d'utilisé).
Une dernière chose sur le branchement, le sens importe peut puisqu'il suffit d'inverser la pince pour inverser le sens.
Image
Pour la découpe du boîtier, je commence par percer avec une mèche de 4mm (vitesse lente, genre visseuse sur batterie)
C'est plutôt un avant trou, pas besoin de perforer entièrement le plastique, la mèche risque de partir dans les ouvertures existantes et d’abîmer le plastique.
Image
Ensuite avec ce genre d'outil, j'agrandis le trou et retire la cloison interne. Pour être honnête j'ai fait avec ce que j'avais.
Image
La résistance de 5.1K est soudé sur la liaison du milieu après avoir coupé une partie. Faite des soudures fines et si possible sur le côté des liaisons.
Le câble U provenant du PCB sera soudé sur la liaison du bas (sous la résistance).
Passons maintenant à la soudure des composants sur le PCB. J'utilise de la soudure de 0.5mm 0.8mm max.
Image
Je commence par les condensateurs (les 22p) ce sont les plus petits (problème approvisionnement) aucun n'est polarisé (pas de sens).
Il faut obligatoirement que le composant soit tenu avant la soudure, j'utilise ce support bricolé en Imp 3D.
Image
Image
J'utilise cette photo modifié V2 (que j'ai imprimé) pour faciliter l'implantation des composants.
Si vous avez un nouveau compteur R7 est à remplacer par une 0 ohm et supprimer R6.
Pour un ancien compteur allez sur ce sujet https://forum-photovoltaique.fr/viewtopic.php?f=110&t=39159
Les kits sont fournis pour les deux versions de compteur.
Image
Voilà le PCB fini, après les condensateurs, les résistances et les composants traversants.
Respecter le sens pour le régulateur, le support (c'est mieux), le quartz n'a bien sur pas de sens de montage.
Image
Côté composants (je nettoie les résidus de soudure avec une brosse à dents imbibées d'acétone)
Image
Notez que j'ai utilisé un isolant entre les deux PCB...je vous le conseille fortement !
Tous les raccordements sont réalisés, il n'y a plus qu'à fermer le boîtier.....pas si simple !
Il faut glisser de travers la partie supérieure (afficheur) sous le jack.....impossible d'expliquer, mais pas d'énervement on y arrive.
Image
Vous y êtes presque....sauf que comme sur la photo, impossible de fermer le boîtier, il manque 1 ou 2mm d'un côté (ou de l'autre) surtout ne pas forcer.
Rappelez-vous de la première photo
Image
Le circuit doit être centré pour que les deux encoches puissent se positionner sur les ergots.
Il est donc soit trop à droite soit trop à gauche.
Je positionne le PCB penché vers le jack.
Sur l'ancien compteur le PCB était positionné le plus bas possible mais avec le composant vert assez volumineux ce n'est pas possible.
Image
Image

Premier test
J'ai utilisé ce câblage, pas pour vérifier que le compteur compte puisque je n'utilise pas la phase après compteur mais pour vérifier que le compteur modifié fonctionne comme prévu.
Image
Attention, le Neutre doit être positionné sur la borne 1 du compteur (à droite), sinon vous aurez la phase sur les -input des SSR et dans ce cas il ne faut pas y mettre les doigts.

J'ai donc testé ce qui était donné sur le site anglais, un circuit passant dans la pince en inverse de l'autre avec une ampoule de 60W comme sur ce schéma.
Pour en quelque sorte simuler une production solaire.
dès la mise sous tension:
--la led verte du compteur s'allume.
--l'afficheur affiche tous les segments 8.8.8.8.8.8.8.
--puis U 1.0
--puis C500
--et enfin 0.0
C'est déjà que la partie alimentation (gros condo) et compteur est OK.

Si l'ampoule 60W est allumée et après environ 20sc l'halogène de 150W (SSR1) commence à scintiller et monte progressivement en puissance.
Puis le moteur de 85W sur le SSR2 se met en marche.
Lorsque j’éteins l'ampoule de 60W , l'halogène de 150W décline progressivement puis le moteur 85W (SSR2) s'arrête.
Logiquement, après un certain temps (140sc) ampoule 60W éteinte, l'halogène de 150W doit faiblement rougeoyer (mais avec certaines pinces la 150W reste éteinte)



si rien ne se passe après l'initialisation du compteur (attendre 140sc), vérifier votre câblage et surtout le jack, il peut y avoir un mauvais contact, retirer et le remettre est parfois bénéfique.

si par contre en éteignant l'ampoule de 60W , la 150W reste allumé, modifier le sens de la pince (pas côté jack) côté pince bleue, on inverse le sens de passage des phases en retournant la pince.

Il ne vous reste plus qu'à câbler dans votre tableau
Image
et de raccorder la pince sur la phase.


FAQ:

--J'ai un Kit en V1 et monté sur un ancien compteur, puis-je installer la V2 avec deux sorties SSR sans changer mon compteur ?
Oui, il suffit de téléverser le nouveau sketch (V2) dans l'Atmega et de câbler les sorties CH1 et CH2 comme sur le nouveau compteur.

--J'ai reçu un Kit15 (les composants à souder sur le PCB) mais j'ai quelques composants en trop ?
Oui, c'est normal.
Le kit15 a été prévu pour un montage dans les compteurs "première génération" et depuis un certain temps les compteurs réceptionnés sont de "deuxième génération".
le kit15 est donc prévu pour les deux modèles. Attention, d’ailleurs, certaines résistances ne sont plus à souder pour la "deuxième génération". (R6 supprimé, R7=0 et rajouter sur le compteur R 5.1K)

--Lors de la mise sous tension du compteur...à part l'initialisation de celui-ci...il ne se passe rien !
Soyez patient....il faut une bonne minute pour que l'optimiseur s'initialise et commence à router...si besoin !

--Tout à l'air de fonctionner, sauf que ça devrait pas router et que la résistance du CE semble être à sa puissance max !
La sonde de courant doit être inversée.
Modifié en dernier par rolrider le 21 mars 2019 00:57, modifié 8 fois.

Avatar du membre
president13
Messages : 412
Enregistré le : 16 sept. 2018 20:45
BDPV : president13
Departement/Region : 31
Professionnel PV : Non

Re: Montage Kit Optimiseur

Messagepar president13 » 31 janv. 2019 14:00

hello,

super tuto.
une question : tu attaques les SSR par du 5V DC? mais il y a aussi le neutre du 230V AC sur l'autre entrée de commande du SSR?
c'est avant dernier schéma qui me fait douter.

tignous84
BDPV
BDPV
Messages : 3303
Enregistré le : 11 avr. 2017 19:53
BDPV : tignous84
Departement/Region : 84
Professionnel PV : Non

Re: Montage Kit Optimiseur

Messagepar tignous84 » 31 janv. 2019 14:20

Merci Pascal :)

Pour notre Président ,comme on n'a pas de transfo d'isolement ,le neutre est commun avec le zéro volt BT
(qui est de 3.3 Volt.)

C'est pourquoi sur le calage externe,il vaut mieux mettre le Neutre à DROITE ;)
Mon installation en autoconstruction:
http://forum-photovoltaique.fr/viewtopi ... 25&t=36255

Mon Optimiseur /compteur:
http://forum-photovoltaique.fr/viewtopi ... 18&t=38146

Ma fiche BDPV
https://www.bdpv.fr/fr/ficheUtilisateur ... =tignous84

Ma devise :Mesurer ,c'est connaître

Avatar du membre
president13
Messages : 412
Enregistré le : 16 sept. 2018 20:45
BDPV : president13
Departement/Region : 31
Professionnel PV : Non

Re: Montage Kit Optimiseur

Messagepar president13 » 31 janv. 2019 14:54

tignous84 a écrit :Merci Pascal :)

Pour notre Président ,comme on n'a pas de transfo d'isolement ,le neutre est commun avec le zéro volt BT
(qui est de 3.3 Volt.)

C'est pourquoi sur le calage externe,il vaut mieux mettre le Neutre à DROITE ;)


ok c'est clair merci. je ne savais pas que ça pouvait se faire. Et en plus je viens de voir en me renseignant que le neutre....n'oscille pas :lol:

a+

Photauconso
Messages : 108
Enregistré le : 20 juil. 2018 13:47
Departement/Region : 37
Professionnel PV : non

Re: Montage Kit Optimiseur

Messagepar Photauconso » 31 janv. 2019 19:12

tignous84 a écrit :Merci Pascal :)

Pour notre Président ,comme on n'a pas de transfo d'isolement ,le neutre est commun avec le zéro volt BT
(qui est de 3.3 Volt.)

C'est pourquoi sur le calage externe,il vaut mieux mettre le Neutre à DROITE ;)


Bonsoir Tignous,
J'ai pas trop le temps de me poser de question en ce moment !!! J'ai un peu le nez dans le guidon au niveau professionnel. J'arrive quand même tant bien que mal à suivre les différents fil de discussion sur le sujet.
Je pense avoir plus de temps les prochaines semaines pour bien comprendre ce nouveau routeur deux voies et nouveau soft. ;)

Par contre j'avais remarqué que tu avais inversé la phase et le neutre sur le compteur du premier routeur et je me demandais pourquoi ? :?:
Par ailleurs dans le nouveau routeur deux voies le neutre AC et le neutre DC semblent commun, comment cela est-il possible ? :?:

Il semblerait que tu répondes à Président13 à ces deux questions.... Sauf que moi je ne suis pas aussi calé que vous en électronique/electricité !!! :shock: :!:
Bref je n'ai rien compris à ta réponse. :cry: (Ni à celle de président13 d'ailleurs) :( :( Serait-il possible que tu développes un peu plus ta réponse ci-dessus tout en répondant peut-être à mes propres questionnements ? :?:
Merci à Toi. :sun: :sun: :sun:

PS : bravo à Rolrider pour le tuto !!!! :D

tignous84
BDPV
BDPV
Messages : 3303
Enregistré le : 11 avr. 2017 19:53
BDPV : tignous84
Departement/Region : 84
Professionnel PV : Non

Re: Montage Kit Optimiseur

Messagepar tignous84 » 31 janv. 2019 20:17

Alors pour faire simple ;
idéalement ,il faudrait isoler par un transformateur la basse tension 5V et 3.3V DC du secteur 230V AC
MAIS pour des question de coût ,les constructeurs fabriquent la basse tension à partir du secteur
via un condensateur et une diode zener.il n'y a pas de séparation galvanique .
Dans le compteur utilisé ,c'est le cas et il se trouve que c'est la phase qui généralement est à droite sur
le bornier qui se trouve commune avec la basse tension.

C'est gênant pour nous qui avons le jack et les commandes SSR qui sortent.
on risque de ramasser la châtaigne en tripotant le jack et en plus ,on ajoute du bruit qui
peut perturber le fonctionnement .
d’où cette petite entrave à la règle ,on met le neutre à droite et on est tranquille. ;)
Mon installation en autoconstruction:
http://forum-photovoltaique.fr/viewtopi ... 25&t=36255

Mon Optimiseur /compteur:
http://forum-photovoltaique.fr/viewtopi ... 18&t=38146

Ma fiche BDPV
https://www.bdpv.fr/fr/ficheUtilisateur ... =tignous84

Ma devise :Mesurer ,c'est connaître

unnovice
Messages : 228
Enregistré le : 05 déc. 2018 20:32
Departement/Region : 64
Professionnel PV : non

Re: Montage Kit Optimiseur

Messagepar unnovice » 08 févr. 2019 08:54

super tuto, je cherchais le premier mais il avait disparu,

concernant le SSR, si j'ai bien suivi, celui du CE a été modifié, pour l'autre sortie c'est un normal.

c'est bien ca?

tignous84
BDPV
BDPV
Messages : 3303
Enregistré le : 11 avr. 2017 19:53
BDPV : tignous84
Departement/Region : 84
Professionnel PV : Non

Re: Montage Kit Optimiseur

Messagepar tignous84 » 08 févr. 2019 08:59

OUI :)
Mon installation en autoconstruction:
http://forum-photovoltaique.fr/viewtopi ... 25&t=36255

Mon Optimiseur /compteur:
http://forum-photovoltaique.fr/viewtopi ... 18&t=38146

Ma fiche BDPV
https://www.bdpv.fr/fr/ficheUtilisateur ... =tignous84

Ma devise :Mesurer ,c'est connaître

rolrider
Messages : 86
Enregistré le : 14 mai 2018 10:35
Departement/Region : 78
Professionnel PV : non

Re: Montage Kit Optimiseur

Messagepar rolrider » 27 févr. 2019 15:07

j'ai rajouté en fin de tuto une "foire aux questions"
pour l'instant...j'en ai qu'une !
mais si vous avez d'autres interrogations ça servira aux autres.

Photauconso
Messages : 108
Enregistré le : 20 juil. 2018 13:47
Departement/Region : 37
Professionnel PV : non

Re: Montage Kit Optimiseur

Messagepar Photauconso » 27 févr. 2019 18:50

rolrider a écrit :j'ai rajouté en fin de tuto une "foire aux questions"
pour l'instant...j'en ai qu'une !
mais si vous avez d'autres interrogations ça servira aux autres.

j'ai lu la FAQ :lol: :lol: :lol: super !!!

Cela répond à ma question je crois... Il n'y a donc finalement que le nouveau fil à rajouter sur la plaque, et souder l'autre bout sur CH2...L'ancien fil qui allait de CH2 à O et qui correspondait au neutre DC ne sert donc plus à rien puisque le neutre se prend sur le neutre commun AC/DC.
Par contre il y a une modification à faire dans le sketch : celle que tu m'as donné dans ton mail....et normalement tout roule.... A suivre quand j'aurais le temps de m'y remettre.

:sun: :sun: :sun: :sun: Pour l'instant mon routeur V1 ancienne génération fonctionne parfaitement encore 8,24 kWh produits aujourd'hui et 4,52 kWh dérivés sur le CE avec 0 kWh d'injection sur le réseau !!!! :sun: :sun: :sun: :sun: :sun: :sun:
Modifié en dernier par Photauconso le 27 févr. 2019 18:51, modifié 1 fois.

apfrance3
Messages : 2
Enregistré le : 12 mars 2019 08:11
Departement/Region : 42
Professionnel PV : non

Re: Montage Kit Optimiseur

Messagepar apfrance3 » 15 mars 2019 08:43

bonjour,je suis nouveau sur le forum et je dit bravo pour cet excellent travail,je voudrais savoir combien on peut tirer d''Ampères sur le SSR2 .Cdlt

tignous84
BDPV
BDPV
Messages : 3303
Enregistré le : 11 avr. 2017 19:53
BDPV : tignous84
Departement/Region : 84
Professionnel PV : Non

Re: Montage Kit Optimiseur

Messagepar tignous84 » 15 mars 2019 09:38

apfrance3 a écrit :bonjour,je suis nouveau sur le forum et je dit bravo pour cet excellent travail,je voudrais savoir combien on peut tirer d''Ampères sur le SSR2 .Cdlt


Salut,c'est écrit dessus ;) le triac est spécifié pour un courant nominal (40 Amp pour celui conseillé.)
il faut aussi veiller à la température du socle .
Mais c'est un faux problème ;les puissances à commuter sont basses sur une installation de 3 kWc
Mon installation en autoconstruction:
http://forum-photovoltaique.fr/viewtopi ... 25&t=36255

Mon Optimiseur /compteur:
http://forum-photovoltaique.fr/viewtopi ... 18&t=38146

Ma fiche BDPV
https://www.bdpv.fr/fr/ficheUtilisateur ... =tignous84

Ma devise :Mesurer ,c'est connaître


Retourner vers « Electronique/Domotique/PV routeur »